3 minute read

구간 곱 구하기

시간 제한 메모리 제한
1 초 256 MB

문제

어떤 N개의 수가 주어져 있다. 그런데 중간에 수의 변경이 빈번히 일어나고 그 중간에 어떤 부분의 곱을 구하려 한다. 만약에 1, 2, 3, 4, 5 라는 수가 있고, 3번째 수를 6으로 바꾸고 2번째부터 5번째까지 곱을 구하라고 한다면 240을 출력하면 되는 것이다. 그리고 그 상태에서 다섯 번째 수를 2로 바꾸고 3번째부터 5번째까지 곱을 구하라고 한다면 48이 될 것이다.

입력

첫째 줄에 수의 개수 N(1 ≤ N ≤ 1,000,000)과 M(1 ≤ M ≤ 10,000), K(1 ≤ K ≤ 10,000) 가 주어진다. M은 수의 변경이 일어나는 횟수이고, K는 구간의 곱을 구하는 횟수이다. 그리고 둘째 줄부터 N+1번째 줄까지 N개의 수가 주어진다. 그리고 N+2번째 줄부터 N+M+K+1 번째 줄까지 세 개의 정수 a,b,c가 주어지는데, a가 1인 경우 b번째 수를 c로 바꾸고 a가 2인 경우에는 b부터 c까지의 곱을 구하여 출력하면 된다.

입력으로 주어지는 모든 수는 0보다 크거나 같고, 1,000,000보다 작거나 같은 정수이다.

출력

첫째 줄부터 K줄에 걸쳐 구한 구간의 곱을 1,000,000,007로 나눈 나머지를 출력한다.

예제 입력 1

5 2 2
1
2
3
4
5
1 3 6
2 2 5
1 5 2
2 3 5

예제 출력 1

240
48

예제 입력 2

5 2 2
1
2
3
4
5
1 3 0
2 2 5
1 3 6
2 2 5

예제 출력 2

0
240

Idea.

  • 중간에 수의 변경이 빈번하게 일어난다. → 구간 배열 구조는 시간이 오래걸린다.
  • 세그먼트 트리 자료구조 이용
  • 백준 2042번의 응용
  • 곱셈임으로 트리 배열의 초기값을 1로 모두 넣어준다.
  • 업데이트는 현재 노드의 양쪽 자식을 찾아서 곱해서 업데이트 해준다.
  • 곱셈 과정에 MOD 연산을 모두 넣어준다. (문제의 조건)

Code.

package tree;

import java.util.Scanner;

public class P11505_segmentTreeMod {
	static long[] tree;
	static int MOD;

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);

		int N = sc.nextInt(); // leaf node quantity 5
		int M = sc.nextInt(); // number of changes 2
		int K = sc.nextInt(); // number of MOD 2

		int treeHeight = 0; // 2^k >= N인 k값을 구한다.k=treeHeight 3

		int x = N;
		while (x != 0) {
			x /= 2;
			treeHeight++;
		}

		int treeSize = (int) Math.pow(2, treeHeight + 1); // 2^3 * 2 결국 2^4 = 16
		int leafNodeStartIndex = treeSize / 2;
		int leftNodeStartIndex = leafNodeStartIndex - 1;

		MOD = 1000000007;
		tree = new long[treeSize + 1];
		for (int i = 0; i < tree.length; i++) { // 곱셈임으로 초깃값을 1로 설정
			tree[i] = 1;
		}
		// save leaf node data in tree
		for (int i = leftNodeStartIndex + 1; i <= leftNodeStartIndex + N; i++) {
			tree[i] = sc.nextLong();
		}

		setTree(treeSize - 1); // 트리 자료 구조

		for (int i = 0; i < M + K; i++) {
			long a = sc.nextLong();
			int start = sc.nextInt(); // 업데이트의 경우 start를 end(value)로 바꿔준다.
			long end = sc.nextLong(); // 구간 곱의 경우 start부터 end까지의 구간 곱

			if (a == 1) {
				updateValue(leftNodeStartIndex + start, end);
			} else if (a == 2) { // 구간 곱
				start = start + leftNodeStartIndex; // tree의 index로 바꿔준다.
				end = end + leftNodeStartIndex;
				System.out.println(getMultiplication(start, (int) end));
			}
		}

	}

	private static long getMultiplication(int start, int end) {
		long partMultiplication = 1;
		while (start <= end) {
			if (start % 2 == 1) { // 부모 노드의 오른쪽에 있다는 뜻 (노드를 선택해준다.)
				partMultiplication = partMultiplication * tree[start] % MOD;
				start++;
			}
			if (end % 2 == 0) { // 부모 노드의 왼쪽에 있다는 뜻 (노드를 선택해준다.)
				partMultiplication = partMultiplication * tree[end] % MOD;
				end--;
			}
			start = start / 2;
			end = end / 2;
		}

		return partMultiplication;
	}

	private static void updateValue(int index, long value) {
		tree[index] = value;
		while (index > 1) { // 현재 노드의 양쪽 자식을 찾아 곱한다.
			index = index / 2;
			tree[index] = tree[index * 2] % MOD * tree[index * 2 + 1] % MOD;
		}

	}

	private static void setTree(int i) {
		while (i != 1) {
			tree[i / 2] = tree[i / 2] * tree[i] % MOD;
			i--;
		}
	}

}

Leave a comment