1 minute read

Mention : 구간 합 구하기 Java11, 앞으로는 슈도코드를 기반으로 문제를 풀어야겠다. 디버깅도 덤🐞

문제

수 N개가 주어졌을 때, i번째 수부터 j번째 수까지 합을 구하는 프로그램을 작성하시오.

입력

첫째 줄에 수의 개수 N과 합을 구해야 하는 횟수 M이 주어진다. 둘째 줄에는 N개의 수가 주어진다. 수는 1,000보다 작거나 같은 자연수이다. 셋째 줄부터 M개의 줄에는 합을 구해야 하는 구간 i와 j가 주어진다.

출력

총 M개의 줄에 입력으로 주어진 i번째 수부터 j번째 수까지 합을 출력한다.

제한

  • 1 ≤ N ≤ 100,000
  • 1 ≤ M ≤ 100,000
  • 1 ≤ i ≤ j ≤ N

예제 입력 1

5 3
5 4 3 2 1
1 3
2 4
5 5

예제 출력 1

12
9
1

First Try (with 슈도코드)

  • ChatGPT 분석 👀 (갓챗지피티…!!!!)
  • 시간 복잡도
    • The time complexity of the above code is O(N) for the first loop where you are filling the “number” array and O(M) for the second loop where you are processing the queries. The time complexity for each query is O(1), since it involves only a few arithmetic operations.
    • Thus, the overall time complexity of the code is O(N + M). If the size of the “number” array (N) is 100,000 and the number of queries (M) is also 100,000, the time complexity will be O(200,000) or simply O(N+M).
    • 배열 O(2n)
    • 구간 합 O(1)
    • O(200,000) → 0.002초
package prefixSum;

import java.util.Scanner;

public class P11659_prefixSum4 {

	public static void main(String[] args) {
		// 수의 개수 N을 입력받는다, 합을 구해야 하는 횟수 M을 입력받는다.
		Scanner sc = new Scanner(System.in);
		int N = sc.nextInt();
		int M = sc.nextInt();
		// 두번째 줄에 N개의 수가 주어진다.
		int[] number = new int[N];
		// N개의 수의 배열을 만들어준다.
		for (int k = 0; k < number.length; k++) {
			number[k] = sc.nextInt();
		}
		// N개의 수의 합 배열을 만들어준다.
		int[] sum = new int[N];
		for (int k = 0; k < number.length; k++) {
			if (k != 0) {
				sum[k] = sum[k - 1] + number[k];
			} else {
				sum[k] = number[k];
			}
		}
		// 세번쨰 줄에 M개의 줄에 합을 구해야하는 구간 i와 j가 주어진다.
		// 합 배열을 이용하여 M개의 구간 합을 구한다.
		for (int k = 0; k < M; k++) {
			int i = sc.nextInt() - 1;
			int j = sc.nextInt() - 1;
			//출력
			if (i != 0) {
				System.out.println(sum[j] - sum[i - 1]);
			} else {
				System.out.println(sum[j]);
			}
		}
	}
}

Leave a comment