2 minute read

구간 합 구하기

시간 제한 메모리 제한
2 초 256 MB

문제

어떤 N개의 수가 주어져 있다. 그런데 중간에 수의 변경이 빈번히 일어나고 그 중간에 어떤 부분의 합을 구하려 한다. 만약에 1,2,3,4,5 라는 수가 있고, 3번째 수를 6으로 바꾸고 2번째부터 5번째까지 합을 구하라고 한다면 17을 출력하면 되는 것이다. 그리고 그 상태에서 다섯 번째 수를 2로 바꾸고 3번째부터 5번째까지 합을 구하라고 한다면 12가 될 것이다.

입력

첫째 줄에 수의 개수 N(1 ≤ N ≤ 1,000,000)과 M(1 ≤ M ≤ 10,000), K(1 ≤ K ≤ 10,000) 가 주어진다. M은 수의 변경이 일어나는 횟수이고, K는 구간의 합을 구하는 횟수이다. 그리고 둘째 줄부터 N+1번째 줄까지 N개의 수가 주어진다. 그리고 N+2번째 줄부터 N+M+K+1번째 줄까지 세 개의 정수 a, b, c가 주어지는데, a가 1인 경우 b(1 ≤ b ≤ N)번째 수를 c로 바꾸고 a가 2인 경우에는 b(1 ≤ b ≤ N)번째 수부터 c(b ≤ c ≤ N)번째 수까지의 합을 구하여 출력하면 된다.

입력으로 주어지는 모든 수는 -2^63보다 크거나 같고, 2^63-1보다 작거나 같은 정수이다.

출력

첫째 줄부터 K줄에 걸쳐 구한 구간의 합을 출력한다. 단, 정답은 -2^63보다 크거나 같고, 2^63-1보다 작거나 같은 정수이다.

예제 입력 1

5 2 2
1
2
3
4
5
1 3 6
2 2 5
1 5 2
2 3 5

예제 출력 1

17
12

Idea.

Code.

package tree;

import java.util.Scanner;

public class P2042_segmentTreePrefixSum {
	static long[] tree;

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);

		int N = sc.nextInt(); // leaf node quantity 5
		int M = sc.nextInt(); // number of changes 2
		int K = sc.nextInt(); // number of prefix sum 2

		int treeHeight = 0; // 2^k >= N 인 k값을 구한다. k = treeHeight 3

		int x = N;
		while (x != 0) {
			x /= 2;
			treeHeight++;
		}

		int treeSize = (int) Math.pow(2, treeHeight + 1); // 2^3 * 2 결국 2^4
		int leafNodeStartIndex = treeSize / 2 - 1; // 수정!leftNodeStartIndex가 되야 맞다. leafNodeStartIndex 는 treeSize/2

		tree = new long[treeSize + 1]; // save leaf node data
		for (int i = leafNodeStartIndex + 1; i <= leafNodeStartIndex + N; i++) {
			tree[i] = sc.nextLong();
		}

		setTree(treeSize - 1); // 트리 자료 구조 완성

		for (int i = 0; i < M + K; i++) {
			long a = sc.nextLong();
			int start = sc.nextInt();
			long end = sc.nextLong();

			if (a == 1) {
				updateValue(leafNodeStartIndex + start, end); // update start를 end로 바꾼다.
			} else if (a == 2) { // prefix sum
				start = start + leafNodeStartIndex; // tree의 index로 바꿔준다.
				end = end + leafNodeStartIndex;
				System.out.println(getSum(start, (int) end));
			} else {
				return;
			}
		}
	}

	private static long getSum(int start, int end) { // 17, 20
		long partSum = 0;
		while (start <= end) {
			if (start % 2 == 1) { // 부모 노드의 오른쪽에 있다는 뜻
				partSum = partSum + tree[start]; // 노드를 선택해준다. (부모노드의 오른쪽에 있음으로)
				start++;
			}
			if (end % 2 == 0) { // 부모 노드의 왼쪽에 있다는 뜻
				partSum = partSum + tree[end]; // 노드를 선택해준다. (부모노드의 왼쪽에 있음으로)
				end--;
			}
			start = start / 2;
			end = end / 2;
		}
		return partSum;
	}

	private static void updateValue(int index, long val) { // update method
		long diff = val - tree[index]; // 인덱스의 값과 바꿀 값 차이
		while (index > 0) {
			tree[index] = tree[index] + diff; // 부모노드를 타고 올라가면서 차이를 더해준다.
			index = index / 2;
		}

	}

	private static void setTree(int i) {
		while (i != 1) {
			tree[i / 2] += tree[i];
			i--;
		}
	}

}

Leave a comment